]> git.uio.no Git - check_linux_bonding.git/blob - nagios-plugins-bonding.spec
release 1.4
[check_linux_bonding.git] / nagios-plugins-bonding.spec
1 # Name of the plugin
2 %global plugin check_linux_bonding
3
4 # No binaries here, do not build a debuginfo package
5 %global debug_package %{nil}
6
7 # SUSE installs Nagios plugins under /usr/lib, even on 64-bit
8 # It also uses noarch for non-binary Nagios plugins and has different
9 # package names for docbook.
10 %if %{defined suse_version}
11 %global nagiospluginsdir /usr/lib/nagios/plugins
12 %global docbookpkg docbook-xsl-stylesheets
13 BuildArch:     noarch
14 %else
15 %global nagiospluginsdir %{_libdir}/nagios/plugins
16 %global docbookpkg docbook-style-xsl
17 %endif
18
19 Name:          nagios-plugins-bonding
20 Version:       1.3.2
21 Release:       1%{?dist}
22 Summary:       Nagios plugin to check Linux bonding interfaces
23
24 Group:         Applications/System
25 License:       GPLv3+
26 URL:           http://folk.uio.no/trondham/software/%{plugin}.html
27 Source0:       http://folk.uio.no/trondham/software/files/%{plugin}-%{version}.tar.gz
28
29 # Since we're also building for RHEL5
30 BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
31
32 # Building requires Docbook XML
33 BuildRequires: libxslt
34 BuildRequires: libxml2
35 BuildRequires: %{docbookpkg}
36
37 # Owns the nagios plugins directory
38 Requires:      nagios-plugins
39
40 # Makes the transition to new package name easier for existing
41 # users of RPM packages
42 Provides:      check_linux_bonding = %{version}-%{release}
43 Obsoletes:     check_linux_bonding < 1.3.2
44
45 %description
46 check_linux_bonding is a plugin for Nagios that checks bonding
47 interfaces on Linux. The plugin is fairly simple and will report any
48 interfaces that are down (both masters and slaves). It will also alert
49 you of bonding interfaces with only one slave, since that usually
50 points to a misconfiguration.
51
52 %prep
53 %setup -q -n %{plugin}-%{version}
54
55 %build
56 pushd man
57 make clean && make
58 popd
59
60 %install
61 rm -rf %{buildroot}
62 install -Dp -m 0755 %{plugin} %{buildroot}%{nagiospluginsdir}/%{plugin}
63 install -Dp -m 0644 man/%{plugin}.8 %{buildroot}%{_mandir}/man8/%{plugin}.8
64
65 %clean
66 rm -rf %{buildroot}
67
68 %files
69 %defattr(-, root, root, -)
70 %doc COPYING CHANGES
71 %{nagiospluginsdir}/%{plugin}
72 %{_mandir}/man8/%{plugin}.8*
73
74
75 %changelog
76 * Fri Dec 14 2012 Trond Hasle Amundsen <t.h.amundsen@usit.uio.no> - 1.3.2-1
77 - Version 1.3.2
78 - New man page format
79 - New package name
80 - Fixed buildrequires and requires
81
82 * Tue Oct 26 2010 Trond Hasle Amundsen <t.h.amundsen@usit.uio.no> - 1.3.1-1
83 - Version 1.3.1
84
85 * Thu Aug 26 2010 Trond Hasle Amundsen <t.h.amundsen@usit.uio.no> - 1.3.0-1
86 - Version 1.3.0
87
88 * Wed Feb 17 2010 Trond Hasle Amundsen <t.h.amundsen@usit.uio.no> - 1.2.1-1
89 - Version 1.2.1
90
91 * Tue Feb 16 2010 Trond Hasle Amundsen <t.h.amundsen@usit.uio.no> - 1.2.0-1
92 - Version 1.2.0
93
94 * Thu Oct  9 2009 Trond Hasle Amundsen <t.h.amundsen@usit.uio.no> - 1.1.0-1
95 - Version 1.1.0
96 - Locations for plugin and man page changed
97
98 * Thu Jul 23 2009 Trond Hasle Amundsen <t.h.amundsen@usit.uio.no> - 1.0.1-1
99 - Version 1.0.1
100
101 * Wed Jun 10 2009 Trond Hasle Amundsen <t.h.amundsen@usit.uio.no> - 1.0.0-1
102 - Initial release 1.0.0