Moving required CMake version from 2.8.4 to 2.8.8
[u/mrichter/AliRoot.git] / HLT / CMakeLists.txt
1 # AliRoot Build System CMakeLists for HLT
2 #
3 # Author: Johny Jose m(johny.jose@cern.ch)
4 #         Port of previous Makefile build to cmake
5
6 cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
7
8 option(HLT_CUDA   "Build HLT GPU tracker using CUDA"   OFF)
9 option(HLT_OPENCL "Build HLT GPU tracker using OpenCL" OFF)
10
11 include("CMakehltdoc.conf")
12
13 file(GLOB PACKAGES CMake*.pkg)
14
15 if(HLT_CUDA)
16   list(APPEND PACKAGES TPCLib/tracking-ca/cagpu/CMakelibAliHLTTPCCAGPU.pkg)
17 endif(HLT_CUDA)
18
19 if(HLT_OPENCL)
20   list(APPEND PACKAGES TPCLib/tracking-ca/cagpu/CMakelibAliHLTTPCCAGPUOpenCL.pkg)
21 endif()
22
23 ALICE_BuildModule()