]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - ACORDE/CMakeLists.txt
ACORDE module
[u/mrichter/AliRoot.git] / ACORDE / CMakeLists.txt
index 01bed4fdc6928ac4fec08401c1efc355f537eae3..7dd12bcc3712ee952c5fbc66b9f7b8578f885d0b 100644 (file)
@@ -1,10 +1,24 @@
-# AliRoot Build System CMakeLists for ACORDE
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+# HMPID libraries
+add_subdirectory(ACORDEbase)
+add_subdirectory(ACORDErec)
+add_subdirectory(ACORDEsim)
 
-file(GLOB PACKAGES CMake*.pkg)
+# Install the macros
+install(DIRECTORY macros DESTINATION ACORDE)
 
-ALICE_BuildModule()
+message(STATUS "ACORDE enabled")