doing backward compatibility correctly
[u/mrichter/AliRoot.git] / ACORDE / libACORDEsim.pkg
index d184f95ba2513278fde06f4422213949f1cdb6b8..167a61ed123885fdae93c5383b6514bcb7736b92 100644 (file)
@@ -1,4 +1,8 @@
-SRCS = AliACORDEv0.cxx AliACORDEv1.cxx
+#-*-Mode: Makefile-*-
+
+SRCS = AliACORDE.cxx AliACORDEv1.cxx AliACORDEhit.cxx \
+       AliACORDEDigitizer.cxx AliACORDETrigger.cxx \
+       AliACORDERawData.cxx 
 
 
 HDRS:= $(SRCS:.cxx=.h)
 
 
 HDRS:= $(SRCS:.cxx=.h)
@@ -6,3 +10,9 @@ HDRS:= $(SRCS:.cxx=.h)
 
 DHDR:=ACORDEsimLinkDef.h
 
 
 DHDR:=ACORDEsimLinkDef.h
 
+ifeq (win32gcc,$(ALICE_TARGET))
+PACKSOFLAGS:= $(SOFLAGS) -L$(ALICE_ROOT)/lib/tgt_$(ALICE_TARGET) \
+                         -lACORDEbase -lACORDErec -lSTEER -lCDB -lSTEERBase \
+                         -lRAWDatabase \
+                         -L$(shell root-config --libdir) -lVMC -lGeom
+endif