doing backward compatibility correctly
[u/mrichter/AliRoot.git] / ACORDE / libACORDEsim.pkg
index e8046028645e08e56f054ee6341b9f201e61ae72..167a61ed123885fdae93c5383b6514bcb7736b92 100644 (file)
@@ -1,4 +1,6 @@
-SRCS = AliACORDEv1.cxx AliACORDEhit.cxx AliACORDEdigit.cxx \
+#-*-Mode: Makefile-*-
+
+SRCS = AliACORDE.cxx AliACORDEv1.cxx AliACORDEhit.cxx \
        AliACORDEDigitizer.cxx AliACORDETrigger.cxx \
        AliACORDERawData.cxx 
 
        AliACORDEDigitizer.cxx AliACORDETrigger.cxx \
        AliACORDERawData.cxx 
 
@@ -8,3 +10,9 @@ HDRS:= $(SRCS:.cxx=.h)
 
 DHDR:=ACORDEsimLinkDef.h
 
 
 DHDR:=ACORDEsimLinkDef.h
 
+ifeq (win32gcc,$(ALICE_TARGET))
+PACKSOFLAGS:= $(SOFLAGS) -L$(ALICE_ROOT)/lib/tgt_$(ALICE_TARGET) \
+                         -lACORDEbase -lACORDErec -lSTEER -lCDB -lSTEERBase \
+                         -lRAWDatabase \
+                         -L$(shell root-config --libdir) -lVMC -lGeom
+endif