]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - ANALYSIS/CMakeLists.txt
doxy: consider comments after last line
[u/mrichter/AliRoot.git] / ANALYSIS / CMakeLists.txt
index dd37d05cfc6ddab35fbf01ce8dfeffcbea55fd89..836848d0bfc720382a3a6cc8dc540ad8cc55788a 100644 (file)
@@ -1,36 +1,25 @@
-# -*- mode: cmake -*-
-# Create a library called "lib<name>" which includes the source files given in
-# the array .
-# The extension is already found.  Any number of sources could be listed here.
-
-set(INCLUDE_DIRECTORIES
-${CMAKE_SOURCE_DIR}/ANALYSIS
-${CMAKE_SOURCE_DIR}/ANALYSIS/Aliengui
-${CMAKE_SOURCE_DIR}/STEER
-${CMAKE_SOURCE_DIR}/TPC
-${CMAKE_SOURCE_DIR}/ITS
-${ROOT_INCLUDE_DIR}
-)
-
-include_directories( ${INCLUDE_DIRECTORIES})
-
-set(LINK_DIRECTORIES
-${ROOT_LIBRARY_DIR}
-) 
-
-link_directories( ${LINK_DIRECTORIES})
-
-SetModule()
-
-include(CMake_libANALYSISalice.txt)
-
-include(CMake_libANALYSIS.txt)
-
-include(CMake_libANALYSISRL.txt)
-
-include(CMake_libAliengui.txt)
-
-include(CMake_binaliengui.txt)
-
-
-
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
+
+add_subdirectory(ANALYSIS)
+add_subdirectory(ANALYSISalice)
+add_subdirectory(ANALYSIScalib)
+add_subdirectory(ESDfilter)
+
+# Installing the macros
+install(DIRECTORY macros DESTINATION ANALYSIS)
+install(DIRECTORY BadChunkFilter DESTINATION ANALYSIS)
+
+message(STATUS "ANALYSIS enabled")