]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - DPMJET/CMakeLists.txt
Double check if SM is running added. Some redundant output removed from SM
[u/mrichter/AliRoot.git] / DPMJET / CMakeLists.txt
index 9de6d54e8e45e63cdb9640142904bd0a5fabe2a8..46bf175f1bd270a41d7d6e8903f377d54e96d0af 100644 (file)
@@ -1,10 +1,84 @@
-# AliRoot Build System CMakeLists for DPMJET
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.4 FATAL_ERROR)
+# Module
+set(MODULE DPMJET)
 
-file(GLOB PACKAGES CMake*.pkg)
+# Module include folder
+include_directories(${AliRoot_SOURCE_DIR}/${MODULE}
+                   )
 
-ALICE_BuildModule()
+# Additional include folders in alphabetical order except ROOT
+include_directories(${ROOT_INCLUDE_DIR}
+                   )
+
+# Sources
+set(SRCS
+  AliDpmJetRndm.cxx
+)
+
+# Use cmake ... -DFLUPRO=<directory containing libflukahp.a> ...
+# if you want to build DPMJEt with Fluka support
+if(FLUPRO)
+  link_directories(${FLUPRO})  
+  set ( FSRCS dpmjet3.0-5F.f phojet1.12-35c4.f user3.0-5F.f openfile.f) 
+else(FLUPRO)
+  set ( FSRCS dpmjet3.0-5.f phojet1.12-35c3.f user3.0-5.f openfile.f)   
+endif(FLUPRO)
+
+# Headers from sources
+string(REPLACE ".cxx" ".h" HDRS "${SRCS}")
+
+# Generate the dictionary
+# It will create G_ARG1.cxx and G_ARG1.h / ARG1 = function first argument
+get_directory_property(incdirs INCLUDE_DIRECTORIES)
+generate_dictionary("${MODULE}" "${MODULE}LinkDef.h" "${HDRS}" "${incdirs}")
+
+# Generate the ROOT map
+# Dependecies
+set(LIBDEPS MathCore microcern)
+generate_rootmap("${MODULE}" "${LIBDEPS}" "${CMAKE_CURRENT_SOURCE_DIR}/${MODULE}LinkDef.h")
+
+# Add a library to the project using the specified source files
+add_library(${MODULE} SHARED ${SRCS} G__${MODULE}.cxx ${FSRCS})
+if(FLUPRO)
+  target_link_libraries(${MODULE} flukahp)
+else(FLUPRO)
+  target_link_libraries(${MODULE})
+endif(FLUPRO)
+
+# Additional compilation flags
+set_target_properties(${MODULE} PROPERTIES COMPILE_FLAGS "")
+
+# Linking the library
+target_link_libraries(${MODULE} ${LIBDEPS})
+
+# System dependent: Modify the way the library is build
+if(${CMAKE_SYSTEM} MATCHES Darwin)
+    set_target_properties(${MODULE} PROPERTIES LINK_FLAGS "-undefined dynamic_lookup")
+endif(${CMAKE_SYSTEM} MATCHES Darwin)
+
+# Installation
+install(TARGETS ${MODULE}
+  ARCHIVE DESTINATION lib
+  LIBRARY DESTINATION lib)
+install(FILES ${HDRS} DESTINATION include)
+
+# Install data files
+install(DIRECTORY . DESTINATION DPMJET FILES_MATCHING PATTERN "*.bin")
+install(DIRECTORY . DESTINATION DPMJET FILES_MATCHING PATTERN "*.dat")
+install(DIRECTORY . DESTINATION DPMJET FILES_MATCHING PATTERN "*.inp")
+
+message(STATUS "${MODULE} enabled")