]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - EMCAL/CMakeLists.txt
CMake: removing qpythia from the depedencies
[u/mrichter/AliRoot.git] / EMCAL / CMakeLists.txt
index a1d5d2d967b4457e0beb819097890029ef0b0c09..2b9aa8f01c4550848c7cda8193af43f990781ff0 100644 (file)
@@ -1,34 +1,32 @@
-# -*- mode: cmake -*-
-# Create a library called "lib<name>" which includes the source files given in
-# the array .
-# The extension is already found.  Any number of sources could be listed here.
-
-set(INCLUDE_DIRECTORIES
-${CMAKE_SOURCE_DIR}/EMCAL
-${CMAKE_SOURCE_DIR}/EMCAL/Calib
-${CMAKE_SOURCE_DIR}/EMCAL/SMcalib
-${CMAKE_SOURCE_DIR}/STEER
-${CMAKE_SOURCE_DIR}/RAW
-${CMAKE_SOURCE_DIR}/ANALYSIS
-${ROOT_INCLUDE_DIR}
-)
-
-include_directories( ${INCLUDE_DIRECTORIES})
-
-set(LINK_DIRECTORIES
-${ROOT_LIBRARY_DIR}
-) 
-
-link_directories( ${LINK_DIRECTORIES})
-
-SetModule()
-
-include(CMake_libEMCALrec.txt)
-
-include(CMake_libEMCALbase.txt)
-
-include(CMake_libEMCALsim.txt)
-
-include(CMake_libEMCALcalib.txt)
-
-
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
+
+# HMPID libraries
+add_subdirectory(EMCALbase)
+add_subdirectory(EMCALUtils)
+add_subdirectory(EMCALraw)
+add_subdirectory(EMCALrec)
+add_subdirectory(EMCALsim)
+
+if(DA)
+    add_subdirectory(DA)
+endif(DA)
+
+# Install the macros, docs
+install(DIRECTORY macros DESTINATION EMCAL)
+install(DIRECTORY doc DESTINATION EMCAL)
+install(DIRECTORY mapping DESTINATION EMCAL)
+
+message(STATUS "EMCAL enabled")