]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - FMD/CMakeLists.txt
Filling BB flags in digit with trigger simulator
[u/mrichter/AliRoot.git] / FMD / CMakeLists.txt
index f9ce2ba239def0baf8ec4da9ece07dffee0d3cfb..4d6ae50f9a758e6652fa20fa6bf8c90ba32ac1bc 100644 (file)
@@ -1,33 +1,38 @@
-# -*- mode: cmake -*-
-# Create a library called "lib<name>" which includes the source files given in
-# the array .
-# The extension is already found.  Any number of sources could be listed here.
-
-set(INCLUDE_DIRECTORIES
-${CMAKE_SOURCE_DIR}/FMD
-${CMAKE_SOURCE_DIR}/FMD/flow
-${CMAKE_SOURCE_DIR}/STEER
-${CMAKE_SOURCE_DIR}/RAW
-${ROOT_INCLUDE_DIR}
-)
-
-include_directories( ${INCLUDE_DIRECTORIES})
-
-set(LINK_DIRECTORIES
-${ROOT_LIBRARY_DIR}
-) 
-
-link_directories( ${LINK_DIRECTORIES})
-
-SetModule()
-
-include(CMake_libFMDbase.txt)
-
-include(CMake_libFMDrec.txt)
-
-include(CMake_libFMDutil.txt)
-
-include(CMake_libFMDflow.txt)
-
-include(CMake_libFMDsim.txt)
-
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
+
+# PMD libraries
+add_subdirectory(FMDbase)
+add_subdirectory(FMDutil)
+add_subdirectory(FMDrec)
+add_subdirectory(FMDsim)
+
+if(DA)
+    add_subdirectory(DA)
+endif()
+
+# Install files to destination
+install(DIRECTORY scripts DESTINATION FMD)
+install(FILES 
+            Config.C
+            MakeFMDFullMisAlignment.C
+            MakeFMDResMisAlignment.C
+            MakeFMDZeroMisAlignment.C
+            Reconstruct.C
+            Simulate.C
+            ViewFMD.C
+        DESTINATION FMD)
+
+message(STATUS "FMD enabled")