]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - HLT/BASE/CMakeLists.txt
adding cmake option HLT_COMPONENT_STATISTICS to enable build with the HLT component...
[u/mrichter/AliRoot.git] / HLT / BASE / CMakeLists.txt
index 585f2763c44e2658a5ca2d3db1ed38dc57b8812c..99b8b3308bfee3b24605b4ade3c5cbf191f5e973 100644 (file)
@@ -42,6 +42,13 @@ if(USE_DLOPEN)
   message(STATUS "Using dlopen() for HLT component libs.")
 endif(USE_DLOPEN)
 
+option(HLT_COMPONENT_STATISTICS "Build HLT component statistics" OFF)
+
+if(HLT_COMPONENT_STATISTICS)
+  add_definitions(-DHLT_COMPONENT_STATISTICS)
+  message(STATUS "HLT component statistics enabled.")
+endif(HLT_COMPONENT_STATISTICS)
+
 # Sources in alphabetical order
 set(SRCS
     AliHLTBlockDataCollection.cxx