]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - HLT/BASE/interface/CMakeLists.txt
Update master to aliroot
[u/mrichter/AliRoot.git] / HLT / BASE / interface / CMakeLists.txt
diff --git a/HLT/BASE/interface/CMakeLists.txt b/HLT/BASE/interface/CMakeLists.txt
new file mode 100644 (file)
index 0000000..02510dc
--- /dev/null
@@ -0,0 +1,64 @@
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
+
+# Module
+set(MODULE HLTinterface)
+
+# Module include folder
+include_directories(${AliRoot_SOURCE_DIR}/HLT/BASE/interface
+                   )
+
+# Additional include folders in alphabetical order except ROOT
+include_directories(${ROOT_INCLUDE_DIR}
+                    ${AliRoot_SOURCE_DIR}/HLT/BASE
+                   )
+
+# Sources in alphabetical order
+set(SRCS
+    AliHLTExternalInterface.cxx
+   )
+
+
+# Headers from sources
+string(REPLACE ".cxx" ".h" HDRS "${SRCS}")
+
+# Generate the dictionary
+# It will create G_ARG1.cxx and G_ARG1.h / ARG1 = function first argument
+get_directory_property(incdirs INCLUDE_DIRECTORIES)
+generate_dictionary("${MODULE}" "HLTinterface-LinkDef.h" "${HDRS}" "${incdirs}")
+
+# Generate the ROOT map
+# Dependencies
+set(LIBDEPS HLTbase)
+generate_rootmap("${MODULE}" "${LIBDEPS}" "${CMAKE_CURRENT_SOURCE_DIR}/${MODULE}LinkDef.h")
+
+# Add a library to the project using the specified source files
+add_library(${MODULE} SHARED ${SRCS} G__${MODULE}.cxx)
+
+# Additional compilation flags
+set_target_properties(${MODULE} PROPERTIES COMPILE_FLAGS "")
+target_link_libraries(${MODULE} HLTbase)
+
+# System dependent: Modify the way the library is build
+if(${CMAKE_SYSTEM} MATCHES Darwin)
+    set_target_properties(${MODULE} PROPERTIES LINK_FLAGS "-undefined dynamic_lookup")
+endif(${CMAKE_SYSTEM} MATCHES Darwin)
+
+# Installation
+install(TARGETS ${MODULE}
+        ARCHIVE DESTINATION lib
+        LIBRARY DESTINATION lib)
+
+install(FILES ${HDRS} DESTINATION include)