]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - HLT/CMakeLists.txt
CMake: removing qpythia from the depedencies
[u/mrichter/AliRoot.git] / HLT / CMakeLists.txt
index abd4eeeb6fa1ca4bc5609debc5ec63774bc70391..008282bbee3f70600c0066ea97adf7d5a71cb9bd 100644 (file)
@@ -1,23 +1,64 @@
-# AliRoot Build System CMakeLists for HLT
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
-
-cmake_minimum_required(VERSION 2.8.4 FATAL_ERROR)
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
 option(HLT_CUDA   "Build HLT GPU tracker using CUDA"   OFF)
 option(HLT_OPENCL "Build HLT GPU tracker using OpenCL" OFF)
 
-include("CMakehltdoc.conf")
+add_definitions(-Duse_aliroot -DUSE_ROOT -DROWHOUGHPARAMS)
 
-file(GLOB PACKAGES CMake*.pkg)
+# AliRoot debug mode
+if(ALIDEBUG)
+    add_definitions(-DDEBUG -D__DEBUG)
+else()
+    add_definitions(-DNDEBUG)
+endif (ALIDEBUG)
 
-if(HLT_CUDA)
-  list(APPEND PACKAGES TPCLib/tracking-ca/cagpu/CMakelibAliHLTTPCCAGPU.pkg)
-endif(HLT_CUDA)
+# MLUC
+if(ALIHLT_MLUCDIR)
+    add_definitions(-Duse_logging)
+    include_directories(${ALIHLT_MLUCDIR}/include)
+    link_directories(${ALIHLT_MLUCDIR}/lib/tgt_${ALICE_TARGET})
+endif (ALIHLT_MLUCDIR) 
 
-if(HLT_OPENCL)
-  list(APPEND PACKAGES TPCLib/tracking-ca/cagpu/CMakelibAliHLTTPCCAGPUOpenCL.pkg)
+add_subdirectory(BASE)
+add_subdirectory(CALO)
+add_subdirectory(comp)
+add_subdirectory(global)
+add_subdirectory(EMCAL)
+add_subdirectory(FMD)
+add_subdirectory(ITS)
+#add_subdirectory(FJWrapper) - not needed
+add_subdirectory(MUON)
+add_subdirectory(pendolino)
+add_subdirectory(PHOS)
+add_subdirectory(RCU)
+add_subdirectory(SampleLib)
+add_subdirectory(TPCLib)
+add_subdirectory(TRD)
+add_subdirectory(trigger)
+add_subdirectory(VZERO)
+add_subdirectory(ZDC)
+# Enable EVE if ROOT has OpenGL support
+if(ROOT_HASOPENGL)
+    add_subdirectory(EVE)
 endif()
+add_subdirectory(QA)
+add_subdirectory(rec)
+add_subdirectory(shuttle)
+add_subdirectory(sim)
+
+include("CMakehltdoc.conf")
 
-ALICE_BuildModule()
+message(STATUS "HLT enabled")