]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - HLT/CMakeLists.txt
Corrected list of libraries to resolve all symbols
[u/mrichter/AliRoot.git] / HLT / CMakeLists.txt
index 8f770035e4612f01e481eceef8ddc5dc94b84e32..59c7f2b1e9474152edc85d0d9d16d7a1536214aa 100644 (file)
@@ -16,7 +16,7 @@
 option(HLT_CUDA   "Build HLT GPU tracker using CUDA"   OFF)
 option(HLT_OPENCL "Build HLT GPU tracker using OpenCL" OFF)
 
-add_definitions(-Duse_aliroot -Duse_root -DROWHOUGHPARAMS)
+add_definitions(-Duse_aliroot -DUSE_ROOT -DROWHOUGHPARAMS)
 
 # AliRoot debug mode
 if(ALIDEBUG)
@@ -51,19 +51,12 @@ add_subdirectory(trigger)
 add_subdirectory(VZERO)
 add_subdirectory(ZDC)
 # Enable EVE if ROOT has OpenGL support
-if(ROOT_HASOPENGL STREQUAL "yes")
+if(ROOT_HASOPENGL)
     add_subdirectory(EVE)
 endif()
-
-
-#file(GLOB PACKAGES CMake*.pkg)
-
-#if(HLT_CUDA)
-#  list(APPEND PACKAGES TPCLib/tracking-ca/cagpu/CMakelibAliHLTTPCCAGPU.pkg)
-#endif(HLT_CUDA)
-
-#if(HLT_OPENCL)
-#  list(APPEND PACKAGES TPCLib/tracking-ca/cagpu/CMakelibAliHLTTPCCAGPUOpenCL.pkg)
-#endif()
+add_subdirectory(QA)
+add_subdirectory(rec)
+add_subdirectory(shuttle)
+add_subdirectory(sim)
 
 message(STATUS "HLT enabled")