]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - HLT/CMakeLists.txt
Corrected list of libraries to resolve all symbols
[u/mrichter/AliRoot.git] / HLT / CMakeLists.txt
index fd03ac78deaa09e1cd047048357b30cbdd53eef5..59c7f2b1e9474152edc85d0d9d16d7a1536214aa 100644 (file)
@@ -1,95 +1,62 @@
-# -*- mode: cmake -*-
-# Create a library called "lib<name>" which includes the source files given in
-# the array .
-# The extension is already found.  Any number of sources could be listed here.
-
-set(INCLUDE_DIRECTORIES
-${CMAKE_SOURCE_DIR}/EMCAL
-${CMAKE_SOURCE_DIR}/HLT
-${CMAKE_SOURCE_DIR}/HLT/BASE
-${CMAKE_SOURCE_DIR}/HLT/BASE/HOMER
-${CMAKE_SOURCE_DIR}/HLT/BASE/interface
-${CMAKE_SOURCE_DIR}/HLT/BASE/util
-${CMAKE_SOURCE_DIR}/HLT/EMCAL
-${CMAKE_SOURCE_DIR}/HLT/ITS
-${CMAKE_SOURCE_DIR}/HLT/MUON
-${CMAKE_SOURCE_DIR}/HLT/MUON/OfflineInterface
-${CMAKE_SOURCE_DIR}/HLT/MUON/OnlineAnalysis
-${CMAKE_SOURCE_DIR}/HLT/MUON/utils
-${CMAKE_SOURCE_DIR}/HLT/PHOS
-${CMAKE_SOURCE_DIR}/HLT/RCU
-${CMAKE_SOURCE_DIR}/HLT/SampleLib
-${CMAKE_SOURCE_DIR}/HLT/TPCLib
-${CMAKE_SOURCE_DIR}/HLT/TPCLib/comp
-${CMAKE_SOURCE_DIR}/HLT/TPCLib/offline
-${CMAKE_SOURCE_DIR}/HLT/TPCLib/tracking-ca
-${CMAKE_SOURCE_DIR}/HLT/TRD
-${CMAKE_SOURCE_DIR}/HLT/comp
-${CMAKE_SOURCE_DIR}/HLT/offline
-${CMAKE_SOURCE_DIR}/HLT/rec
-${CMAKE_SOURCE_DIR}/HLT/shuttle
-${CMAKE_SOURCE_DIR}/HLT/sim
-${CMAKE_SOURCE_DIR}/HLT/tracking-ca
-${CMAKE_SOURCE_DIR}/HLT/trigger
-${CMAKE_SOURCE_DIR}/ITS
-${CMAKE_SOURCE_DIR}/MUON
-${CMAKE_SOURCE_DIR}/MUON/mapping
-${CMAKE_SOURCE_DIR}/PHOS
-${CMAKE_SOURCE_DIR}/RAW
-${CMAKE_SOURCE_DIR}/STEER
-${CMAKE_SOURCE_DIR}/TPC
-${CMAKE_SOURCE_DIR}/TRD
-${CMAKE_SOURCE_DIR}/global
-${ROOT_INCLUDE_DIR}
-)
-
-include_directories( ${INCLUDE_DIRECTORIES})
-
-set(LINK_DIRECTORIES
-${ROOT_LIBRARY_DIR}
-) 
-
-link_directories( ${LINK_DIRECTORIES})
-
-ADD_DEFINITIONS(-Duse_aliroot -Duse_root -DUSE_ROOT -DROWHOUGHPARAMS -Duse_reconstruction -Duse_newio -DROOTVERSION=\"unchecked\" -DALIROOTVERSION=\"unchecked\" -D__ROOT__ -DUSE_ALILOG -DLINUX -DLIBHLTSIM_VERSION=0)
-
-SetModule()
-
-Include(CMake_libAliHLTHOMER.txt)
-
-Include(CMake_libHLTinterface.txt)
-
-Include(CMake_libAliHLTUtil.txt)
-
-Include(CMake_libAliHLTSample.txt)
-
-Include(CMake_libAliHLTRCU.txt)
-
-Include(CMake_libHLTshuttle.txt)
-
-Include(CMake_libAliHLTTrigger.txt)
-
-Include(CMake_libAliHLTMUON.txt)
-
-Include(CMake_libHLTrec.txt)
-
-Include(CMake_libHLTbase.txt)
-
-Include(CMake_libAliHLTGlobal.txt)
-
-Include(CMake_libAliHLTTPC.txt)
-
-Include(CMake_libAliHLTTRD.txt)
-
-Include(CMake_libAliHLTComp.txt)
-
-Include(CMake_libAliHLTITS.txt)
-
-Include(CMake_libHLTsim.txt)
-
-Include(CMake_libAliHLTPHOS.txt)
-
-Include(CMake_libAliHLTEMCAL.txt)
-
-Include(CMake_bindHLTdumpraw.txt)
-
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
+
+option(HLT_CUDA   "Build HLT GPU tracker using CUDA"   OFF)
+option(HLT_OPENCL "Build HLT GPU tracker using OpenCL" OFF)
+
+add_definitions(-Duse_aliroot -DUSE_ROOT -DROWHOUGHPARAMS)
+
+# AliRoot debug mode
+if(ALIDEBUG)
+    add_definitions(-DDEBUG -D__DEBUG)
+else()
+    add_definitions(-DNDEBUG)
+endif (ALIDEBUG)
+
+# MLUC
+if(ALIHLT_MLUCDIR)
+    add_definitions(-Duse_logging)
+    include_directories(${ALIHLT_MLUCDIR}/include)
+    link_directories(${ALIHLT_MLUCDIR}/lib/tgt_${ALICE_TARGET})
+endif (ALIHLT_MLUCDIR) 
+
+add_subdirectory(BASE)
+add_subdirectory(CALO)
+add_subdirectory(comp)
+add_subdirectory(global)
+add_subdirectory(EMCAL)
+add_subdirectory(FMD)
+add_subdirectory(ITS)
+add_subdirectory(JET)
+add_subdirectory(MUON)
+add_subdirectory(pendolino)
+add_subdirectory(PHOS)
+add_subdirectory(RCU)
+add_subdirectory(SampleLib)
+add_subdirectory(TPCLib)
+add_subdirectory(TRD)
+add_subdirectory(trigger)
+add_subdirectory(VZERO)
+add_subdirectory(ZDC)
+# Enable EVE if ROOT has OpenGL support
+if(ROOT_HASOPENGL)
+    add_subdirectory(EVE)
+endif()
+add_subdirectory(QA)
+add_subdirectory(rec)
+add_subdirectory(shuttle)
+add_subdirectory(sim)
+
+message(STATUS "HLT enabled")