]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - HLT/configure.ac
Protection against division by zero.
[u/mrichter/AliRoot.git] / HLT / configure.ac
index 72042a972b07d9444fb45966310b468f0ecb9810..6873e1189d9b9ddc504dfd0ce62c8d70d33d73e6 100644 (file)
@@ -734,10 +734,11 @@ else
     # AliTRDclusterizer::SetRawVersion() requires >v4-07-Release
     # changed to AliTRDrecoParam::SetSeedingOn() due to revision 26327, Mon Jun 2 2008
     # changed to AliTRDReconstructor::SetStreamLevel() due to revision 27797, Tue Aug 5 2008
+    # changed to AliTRDReconstructor::SetClusters() according to revision 28069, Mon Aug 18 2008
     AC_MSG_CHECKING([for required functions in AliTRDReconstructor])
     AC_COMPILE_IFELSE([AC_LANG_PROGRAM([#include <AliTRDReconstructor.h>], 
                                        [AliTRDReconstructor r;
-                                      r.SetStreamLevel(0)])],
+                                      r.SetClusters(0)])],
                                        [], 
                                       [enable_trd="no...requires.AliRoot>v4-14-Release"])
     AC_MSG_RESULT([$enable_trd])       
@@ -757,6 +758,45 @@ AC_MSG_CHECKING([whether to compile TRD library])
 AC_MSG_RESULT([$enable_module])
 AC_SUBST([ALITRD_LIBS])
 
+dnl ------------------------------------------------------------------
+AH_TEMPLATE([HLT_FMD],[hlt fmd library])
+
+ALIFMD_LIBS=$ALIHLTMODULE_LIBS
+CHECK_HLTMODULE([fmd],
+               [], [],
+               [], [-L$ROOTLIBDIR], [$ROOTLIBS $ADD_ROOTLIBS],
+               [], [-L$ROOTLIBDIR $ALIROOT_LDFLAGS],
+               [$ROOTLIBS $ADD_ROOTLIBS $ALIROOT_LIBS])
+
+if test "x$enable_module" = "xmissheader"; then
+  enable_module="no...requires.AliRoot>v4-15-Release"
+  enable_fmd="no...requires.AliRoot>v4-15-Release"
+elif test "x$enable_module" = "xforce"; then
+  enable_fmd="yes"
+else
+  enable_fmd=$enable_module
+  if test "x$enable_fmd" = "xyes" ; then
+    AC_LANG_PUSH(C++)
+    save_CPPFLAGS="$CPPFLAGS"
+    CPPFLAGS="$save_CPPFLAGS $ALIROOT_CPPFLAGS -I$ALICE_ROOT/FMD"
+    AC_MSG_RESULT([$enable_fmd])
+    AC_LANG_POP(C++)
+    CPPFLAGS="$save_CPPFLAGS"
+  fi
+fi
+
+if test "x$enable_fmd" = "xyes" ; then
+  AC_DEFINE(HLT_FMD)
+  ALIFMD_LIBS=$ALIHLTMODULE_LIBS
+else
+  enable_module=$enable_fmd
+fi
+AM_CONDITIONAL(EN_HLT_FMD, test x$enable_fmd = xyes)
+AC_MSG_CHECKING([whether to compile FMD library])
+AC_MSG_RESULT([$enable_module])
+AC_SUBST([ALIFMD_LIBS])
+
+
 dnl ------------------------------------------------------------------
 AH_TEMPLATE([HLT_MUON],[hlt dimuon library])
 
@@ -841,7 +881,7 @@ AH_TEMPLATE([HLT_ITS],[hlt its library])
 
 ALIITS_LIBS=
 CHECK_HLTMODULE([its],
-               [], [$ALIROOT_CPPFLAGS],
+               [AliITSCompressRawDataSDD.h], [$ALIROOT_CPPFLAGS -I$ALICE_ROOT/ITS],
                [Gui RAWDatasim], [-L$ROOTLIBDIR], [$ROOTLIBS $ADD_ROOTLIBS],
                [ITSbase ITSrec], [-L$ROOTLIBDIR $ALIROOT_LDFLAGS], 
                [$ROOTLIBS $ADD_ROOTLIBS $ALIROOT_LIBS])