]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - HLT/rec/Makefile.am
- added libPHOSshuttle to PHOS libraries
[u/mrichter/AliRoot.git] / HLT / rec / Makefile.am
index d0e17172ace00e9eddb375a1329889760f6ee8ad..de8e0f2d171e859be87c1e37f99da1a91c4d873a 100644 (file)
@@ -3,20 +3,15 @@
 
 MODULE                         = HLTrec
 
-SUBDIRS                        = 
+SUBDIRS                        = . test
 
 EXTRA_DIST                     = 
 
-AM_CPPFLAGS                    = -DMODULE=$(MODULE) \
-                                 $(PACKCXXFLAGS) \
-                                 @ALIROOT_CPPFLAGS@         \
-                                 -I$(top_srcdir)/BASE
-
 # library definition
 lib_LTLIBRARIES                        =  libHLTrec.la
 
 # version info for the library
-LIBRARY_VERSION                        = "$(LIBHLTREC_VERSION):0:0"
+LIBRARY_VERSION                        = "$(LIBHLTREC_VERSION):0:1"
 
 # MODDIR is set by the AliRoot build system and denotes the topdir
 # of the module, we must set it since the package definition libHLTrec.pkg
@@ -25,6 +20,13 @@ MODDIR                               = $(top_srcdir)
 PKGDEF                         = $(MODDIR)/libHLTrec.pkg
 include $(top_srcdir)/libHLTrec.pkg
 
+# compiler flags
+AM_CPPFLAGS                    = -DMODULE=$(MODULE) \
+                                 $(PACKCXXFLAGS) \
+                                 $(foreach i, $(EINCLUDE),  \
+                                       $(shell echo $(i) | sed -e "/HLT\//!d" -e "s|HLT/|-I$(top_srcdir)/|")) \
+                                 $(foreach i, $(EINCLUDE),  \
+                                       $(shell echo $(i) | sed -e "/HLT\//d" -e "s|^|-I$(ALICE_ROOT)/|"))
 # library sources
 libHLTrec_la_SOURCES           = $(MODULE_SRCS)