]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - HMPID/CMakeLists.txt
Do not include from subdirectories
[u/mrichter/AliRoot.git] / HMPID / CMakeLists.txt
index a22b9baf6f0117a2574e766c83a168eee87c2f44..571d3bfd145af3bfe4db4161f43def7946960266 100644 (file)
@@ -1,27 +1,25 @@
-# -*- mode: cmake -*-
-# Create a library called "lib<name>" which includes the source files given in
-# the array .
-# The extension is already found.  Any number of sources could be listed here.
-
-set(INCLUDE_DIRECTORIES
-${CMAKE_SOURCE_DIR}/HMPID
-${CMAKE_SOURCE_DIR}/STEER
-${CMAKE_SOURCE_DIR}/RAW
-${ROOT_INCLUDE_DIR}
-)
-
-include_directories( ${INCLUDE_DIRECTORIES})
-
-set(LINK_DIRECTORIES
-${ROOT_LIBRARY_DIR}
-) 
-
-link_directories( ${LINK_DIRECTORIES})
-
-SetModule()
-
-include(CMake_libHMPIDbase.txt)
-
-include(CMake_libHMPIDsim.txt)
-
-include(CMake_libHMPIDrec.txt)
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
+
+# HMPID libraries
+add_subdirectory(HMPIDbase)
+add_subdirectory(HMPIDrec)
+add_subdirectory(HMPIDsim)
+
+if(DA)
+    add_subdirectory(DA)
+endif(DA)
+
+message(STATUS "HMPID enabled")