Changes needed by ICC/IFC compiler (Intel)
[u/mrichter/AliRoot.git] / ITS / AliITSgeomSPD.cxx
index ed33469..e9b7acf 100644 (file)
 
 /*
 $Log$
+Revision 1.14  2001/10/19 21:32:35  nilsen
+Minor changes to remove compliation warning on gcc 2.92.2 compiler, and
+cleanded up a little bit of code.
+
 Revision 1.13  2001/10/12 22:07:20  nilsen
 A patch for C++ io manipulation functions so that they will work both
 with GNU gcc 2.96 and GNU gcc 3.01 compilers. Needs to be tested with
@@ -190,8 +194,12 @@ void AliITSgeomSPD::Print(ostream *os) const {
     Int_t fmt;
 #endif
 #else
+#if defined __ICC
+    ios::fmtflags fmt;
+#else
     Int_t fmt;
 #endif
+#endif
 
     fmt = os->setf(ios::scientific); // set scientific floating point output
     *os << "TBRIK" << " ";
@@ -249,6 +257,10 @@ istream &operator>>(istream &is,AliITSgeomSPD &r){
 
 /*
 $Log$
+Revision 1.14  2001/10/19 21:32:35  nilsen
+Minor changes to remove compliation warning on gcc 2.92.2 compiler, and
+cleanded up a little bit of code.
+
 Revision 1.13  2001/10/12 22:07:20  nilsen
 A patch for C++ io manipulation functions so that they will work both
 with GNU gcc 2.96 and GNU gcc 3.01 compilers. Needs to be tested with
@@ -358,6 +370,10 @@ istream &operator>>(istream &is,AliITSgeomSPD300 &r){
 //=====================================================================
 /*
 $Log$
+Revision 1.14  2001/10/19 21:32:35  nilsen
+Minor changes to remove compliation warning on gcc 2.92.2 compiler, and
+cleanded up a little bit of code.
+
 Revision 1.13  2001/10/12 22:07:20  nilsen
 A patch for C++ io manipulation functions so that they will work both
 with GNU gcc 2.96 and GNU gcc 3.01 compilers. Needs to be tested with
@@ -497,6 +513,10 @@ istream &operator>>(istream &is,AliITSgeomSPD425Short &r){
 
 /*
 $Log$
+Revision 1.14  2001/10/19 21:32:35  nilsen
+Minor changes to remove compliation warning on gcc 2.92.2 compiler, and
+cleanded up a little bit of code.
+
 Revision 1.13  2001/10/12 22:07:20  nilsen
 A patch for C++ io manipulation functions so that they will work both
 with GNU gcc 2.96 and GNU gcc 3.01 compilers. Needs to be tested with