]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - ITS/CMakeLists.txt
Double check if SM is running added. Some redundant output removed from SM
[u/mrichter/AliRoot.git] / ITS / CMakeLists.txt
index 90292be251bf00237e072919e8959ec911131c84..4e05e4a77fb2577850a836661d697f46fb52c1ed 100644 (file)
@@ -1,13 +1,30 @@
-# AliRoot Build System CMakeLists for ITS
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+add_subdirectory(ITSbase)
+add_subdirectory(ITSrec)
+add_subdirectory(ITSsim)
+add_subdirectory(UPGRADE)
 
-file(GLOB PACKAGES CMake*.pkg)
+if(DA)
+    add_subdirectory(DA)
+endif(DA)
 
-ALICE_BuildModule()
-#
-ADD_SUBDIRECTORY(UPGRADE)
+# Macros
+install(DIRECTORY oldmacros DESTINATION ITS)
+install(DIRECTORY macrosSDD DESTINATION ITS)
 
+
+message(STATUS "ITS enabled")