]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - MONITOR/monitorGDC/CMakeLists.txt
CMake: Using FindDIM to set include path and linking library
[u/mrichter/AliRoot.git] / MONITOR / monitorGDC / CMakeLists.txt
index 8d4f9f5b883f4231afc6d446d76cf45587b8dec9..652bd05f33589181447aea926033786f78f0f262 100644 (file)
@@ -20,7 +20,8 @@ include_directories(${AliRoot_SOURCE_DIR}/MONITOR/${MODULE}
                    )
 
 # Additional include folders in alphabetical order
-include_directories(${AliRoot_SOURCE_DIR}
+include_directories(${ROOT_INCLUDE_DIR}
+                              ${AliRoot_SOURCE_DIR}
                    )
 
 if(DATE_FOUND)
@@ -40,10 +41,6 @@ set(SRCS
 # Headers from sources
 string(REPLACE ".cxx" ".h" HDRS "${SRCS}")
 
-if(DIMDIR AND ODIR)
-    link_directories(${DIMDIR}/${ODIR})
-endif()
-
 # Add an executable to the project using the specified source files
 add_executable(${MODULE} ${SRCS})
 
@@ -78,4 +75,4 @@ set_target_properties(${MODULE} PROPERTIES COMPILE_FLAGS "${MODULE_COMPILE_FLAGS
 set_target_properties(${MODULE} PROPERTIES LINK_FLAGS "${MODULE_LINK_FLAGS}")
 
 # Installation
-install(TARGETS ${MODULE} RUNTIME DESTINATION bin)
\ No newline at end of file
+install(TARGETS ${MODULE} RUNTIME DESTINATION bin)