]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - MUON/CMakeLists.txt
renaming function to avoid library conflict (discovered in test/generators/TUHKMgen)
[u/mrichter/AliRoot.git] / MUON / CMakeLists.txt
index 312ea08b080335c54557f999dbedbd348672d58f..60454e3bed133a37ff9a9c6f197240456b587f3b 100644 (file)
@@ -1,10 +1,40 @@
-# AliRoot Build System CMakeLists for MUON
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+# MUON libraries
+add_subdirectory(MUONcore)
+add_subdirectory(MUONbase)
+add_subdirectory(MUONcalib)
+add_subdirectory(MUONcalign)
+add_subdirectory(MUONevaluation)
+add_subdirectory(MUONgeometry)
+add_subdirectory(MUONgraphics)
+add_subdirectory(MUONmapping)
+add_subdirectory(MUONmpgraphics)
+add_subdirectory(MUONraw)
+add_subdirectory(MUONrec)
+add_subdirectory(MUONshuttle)
+add_subdirectory(MUONsim)
+add_subdirectory(MUONtrigger)
+add_subdirectory(mchview)
 
-file(GLOB PACKAGES CMake*.pkg)
+if(DA)
+    add_subdirectory(DA)
+endif(DA)
 
-ALICE_BuildModule()
+# Install data folder
+install(DIRECTORY data DESTINATION MUON)
+
+message(STATUS "MUON enabled")