]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - MUON/MUONcalib/CMakeLists.txt
Reading muon trigger scalers with the DA of the muon trigger and transfer
[u/mrichter/AliRoot.git] / MUON / MUONcalib / CMakeLists.txt
index b1d01848ed1a35dc339c319a29c89adeec514989..eaaaf44ed2b6bac87776febdd05443db236ae39b 100644 (file)
@@ -20,7 +20,7 @@ set(MODULE MUONcalib)
 include_directories(${AliRoot_SOURCE_DIR}/MUON/${MODULE})
 
 # Additional include folders in alphabetical order except ROOT
-include_directories(${ROOT_INCLUDE_DIRS}
+include_directories(${ROOT_INCLUDE_DIR}
                     ${AliRoot_SOURCE_DIR}/MUON/MUONcore
                     ${AliRoot_SOURCE_DIR}/MUON/MUONmapping
                     ${AliRoot_SOURCE_DIR}/STEER/CDB
@@ -49,6 +49,7 @@ set(SRCS
     AliMUONTriggerEfficiencyCells.cxx
     AliMUONTriggerIO.cxx
     AliMUONTriggerLut.cxx
+    AliMUONTriggerScalers.cxx
     AliMUONVCalibParam.cxx
     AliMUONVTrackerData.cxx
    )
@@ -73,14 +74,20 @@ generate_rootmap("${MODULE}" "${LIBDEPS}" "${CMAKE_CURRENT_SOURCE_DIR}/${MODULE}
 # Create an object to be reused in case of static libraries 
 # Otherwise the sources will be compiled twice
 add_library(${MODULE}-object OBJECT ${SRCS} G__${MODULE}.cxx)
+# Follow headers dependencies
+add_dependencies(${MODULE}-object ${ALIROOT_DEPENDENCIES})
 # Add a library to the project using the object
 add_library(${MODULE} SHARED $<TARGET_OBJECTS:MUONcalib-object>)
 
 # linking
 target_link_libraries(${MODULE} ${ALIROOT_DEPENDENCIES} ${ROOT_DEPENDENCIES})
 
+# Setting the correct headers for the object as gathered from the dependencies
+target_include_directories(${MODULE}-object PUBLIC $<TARGET_PROPERTY:${MODULE},INCLUDE_DIRECTORIES>)
+set_target_properties(${MODULE}-object PROPERTIES COMPILE_DEFINITIONS $<TARGET_PROPERTY:${MODULE},COMPILE_DEFINITIONS>)
+
 # Additional compilation flags
-set_target_properties(${MODULE}-object PROPERTIES COMPILE_FLAGS "-O -g -fPIC")
+set_target_properties(${MODULE}-object PROPERTIES COMPILE_FLAGS " ")
 
 # System dependent: Modify the way the library is build
 if(${CMAKE_SYSTEM} MATCHES Darwin)
@@ -102,6 +109,10 @@ if(ALIROOT_STATIC)
     # list of shared dependencies / the name of the variable containing the list of static ones
     generate_static_dependencies("${ALIROOT_DEPENDENCIES}" "STATIC_ALIROOT_DEPENDENCIES")
     target_link_libraries(${MODULE}-static ${STATIC_ALIROOT_DEPENDENCIES} Root)
+    
+    # Public include folders that will be propagated to the dependecies
+    target_include_directories(${MODULE}-static PUBLIC ${incdirs})
+
     set_target_properties(${MODULE}-static PROPERTIES LINK_FLAGS "-Wl,--whole-archive")
 
     # Installation