]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - MUON/MUONsim/CMakeLists.txt
VZERO DAs + Object target dependencies
[u/mrichter/AliRoot.git] / MUON / MUONsim / CMakeLists.txt
index ab36d17ec1e7679778940962dcaa3ff2f34f6c15..e92793a14140360dfb646bd50533b0fd8c9ea5fc 100644 (file)
@@ -86,6 +86,8 @@ generate_rootmap("${MODULE}" "${LIBDEPS}" "${CMAKE_CURRENT_SOURCE_DIR}/${MODULE}
 # Create an object to be reused in case of static libraries 
 # Otherwise the sources will be compiled twice
 add_library(${MODULE}-object OBJECT ${SRCS} G__${MODULE}.cxx)
+# Follow headers dependencies
+add_dependencies(${MODULE}-object ${ALIROOT_DEPENDENCIES})
 # Add a library to the project using the object
 add_library(${MODULE} SHARED $<TARGET_OBJECTS:MUONsim-object>)