]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - PWG/CMakeLists.txt
Converting PWG/TRD to native cmake
[u/mrichter/AliRoot.git] / PWG / CMakeLists.txt
index 2535d33dd66aece1d4c0072ba3f03831d7acf019..631c27f167a27c6320e0afb09314a087324ebc6e 100644 (file)
@@ -1,10 +1,24 @@
-# AliRoot Build System CMakeLists for PWG
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+# Include the libraries
+add_subdirectory (Tools)
+add_subdirectory (Glauber)
+add_subdirectory (muon)
+add_subdirectory (EMCAL)
+add_subdirectory (FLOW)
+add_subdirectory (TRD)
 
-file(GLOB PACKAGES CMake*.pkg)
-
-ALICE_BuildModule()
+message(STATUS "PWG enabled")