]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - PYTHIA6/pythia6/CMakeLists.txt
Resolving all symbols in the library
[u/mrichter/AliRoot.git] / PYTHIA6 / pythia6 / CMakeLists.txt
index 9fc8fed0c416fb7e0a73eac0f3f9c8f10a382b0c..3027e57b472d3d3cd8614880b3f5e161cec7ae76 100644 (file)
@@ -53,7 +53,7 @@ generate_dictionary("${MODULE}" "${MODULE}LinkDef.h" "${HDRS}" "${incdirs}")
 
 # Generate the ROOT map
 # Dependecies
-set(LIBDEPS)
+set(LIBDEPS MathCore lhapdf)
 generate_rootmap("${MODULE}" "${LIBDEPS}" "${CMAKE_CURRENT_SOURCE_DIR}/${MODULE}LinkDef.h")
 
 
@@ -63,6 +63,9 @@ add_library(${MODULE} SHARED ${SRCS} G__${MODULE}.cxx ${FSRCS} ${CSRCS})
 # Additional compilation flags
 set_target_properties(${MODULE} PROPERTIES COMPILE_FLAGS "")
 
+# Linking the library
+target_link_libraries(${MODULE} ${LIBDEPS})
+
 # System dependent: Modify the way the library is build
 if(${CMAKE_SYSTEM} MATCHES Darwin)
     set_target_properties(${MODULE} PROPERTIES LINK_FLAGS "-undefined dynamic_lookup")