]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - PYTHIA8/CMakeLists.txt
Generation of dictionaries and rootmaps with Root6
[u/mrichter/AliRoot.git] / PYTHIA8 / CMakeLists.txt
index d3fc79746f77e8a54efa1513f5afc554737cf8cb..3880d6818460178072d4e03bb1b493247d623fc6 100644 (file)
@@ -1,10 +1,23 @@
-# AliRoot Build System CMakeLists for PYTHIA8
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+# Include the libraries
+add_subdirectory (AliPythia8)
+add_subdirectory (pythia8175)
 
-file(GLOB PACKAGES CMake*.pkg)
+# Data needed for running PYTHIA8
+install(DIRECTORY pythia8175/xmldoc DESTINATION PYTHIA8/pythia8175)
 
-ALICE_BuildModule()
+message(STATUS "PYTHIA8 enabled")