]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - PYTHIA8/CMakeLists.txt
New histograms for centrality and multiplcity checks (Gian Michele)
[u/mrichter/AliRoot.git] / PYTHIA8 / CMakeLists.txt
index acb1930897ba53533213bc4c50e604367ce2d01f..aeb6be10f1a82cd0362a850c1a5b5ae3a272321e 100644 (file)
@@ -1,24 +1,10 @@
-# -*- mode: cmake -*-
+# AliRoot Build System CMakeLists for PYTHIA8
+#
+# Author: Johny Jose m(johny.jose@cern.ch)
+#         Port of previous Makefile build to cmake
 
-# Create a library called "lib<name>" which includes the source files given in
-# the array .
-# The extension is already found.  Any number of sources could be listed here.
+cmake_minimum_required(VERSION 2.8.4 FATAL_ERROR)
 
-set(INCLUDE_DIRECTORIES
-${CMAKE_SOURCE_DIR}/PYTHIA8
-${ALIROOT_INSTALL_DIR}/include 
-${ROOT_INCLUDE_DIR}
-)
-
-include_directories( ${INCLUDE_DIRECTORIES})
-
-set(LINK_DIRECTORIES
-${ROOT_LIBRARY_DIR}
-) 
-
-link_directories( ${LINK_DIRECTORIES})
-
-SetModule()
-
-include(CMake_libAliPythia8.txt)
+file(GLOB PACKAGES CMake*.pkg)
 
+ALICE_BuildModule()