]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - RAW/CMakeLists.txt
Fix for FMD DA
[u/mrichter/AliRoot.git] / RAW / CMakeLists.txt
index dc7f021d2fae2a624e8b052327fadef18da64826..801c83cb1772c056d84cb355b899451b1bbe38ca 100644 (file)
@@ -1,10 +1,25 @@
-# AliRoot Build System CMakeLists for RAW
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+# include the libraries
+add_subdirectory(RAWDatabase)
+add_subdirectory(RAWDatarec)
+add_subdirectory(RAWDatasim)
+add_subdirectory(RAWDatarecOnline)
+add_subdirectory(MDC)
+add_subdirectory(alirawdump)
+add_subdirectory(alimdc)
 
-file(GLOB PACKAGES CMake*.pkg)
-
-ALICE_BuildModule()
+add_subdirectory(dateStream)