]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - RAW/CMakeLists.txt
No need for CMAKE_Fortran_FLAGS -cpp, corrected list of files, adding definion -DCTEQ
[u/mrichter/AliRoot.git] / RAW / CMakeLists.txt
index f3de3fa8e2e03f2661f5b2354b643a853e50c9e9..801c83cb1772c056d84cb355b899451b1bbe38ca 100644 (file)
@@ -1,40 +1,25 @@
-# -*- mode: cmake -*-
-# Create a library called "lib<name>" which includes the source files given in
-# the array .
-# The extension is already found.  Any number of sources could be listed here.
-
-set(INCLUDE_DIRECTORIES
-RAW
-${CMAKE_SOURCE_DIR}/RAW
-${CMAKE_SOURCE_DIR}/STEER
-${ROOT_INCLUDE_DIR}
-)
-
-include_directories( ${INCLUDE_DIRECTORIES})
-
-set(LINK_DIRECTORIES
-${ROOT_LIBRARY_DIR}
-) 
-
-link_directories( ${LINK_DIRECTORIES})
-
-SetModule()
-
-include(CMake_libRAWDatasim.txt)
-
-include(CMake_libMDC.txt)
-
-include(CMake_libMDCFilter.txt)
-
-include(CMake_libRAWDatarec.txt)
-
-include(CMake_libRAWDatabase.txt)
-
-include(CMake_libRAWDatarecOnline.txt)
-
-include(CMake_binalimdc.txt)
-
-include(CMake_binalirawdump.txt)
-
-include(CMake_bindateStream.txt)
-
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
+
+# include the libraries
+add_subdirectory(RAWDatabase)
+add_subdirectory(RAWDatarec)
+add_subdirectory(RAWDatasim)
+add_subdirectory(RAWDatarecOnline)
+add_subdirectory(MDC)
+add_subdirectory(alirawdump)
+add_subdirectory(alimdc)
+
+add_subdirectory(dateStream)