]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - STAT/CMakeLists.txt
TuneA settings removed from kPyJets
[u/mrichter/AliRoot.git] / STAT / CMakeLists.txt
index b4a03d89cde89a97878cd5f5afa6f372f6a6e939..6ad2e5db72330acc312ee10dc50ae4bd2d1c0b9e 100644 (file)
@@ -1,10 +1,73 @@
-# AliRoot Build System CMakeLists for STAT
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
-#
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-file(GLOB PACKAGES CMake*.pkg)
+# Module
+set(MODULE STAT)
 
-ALICE_BuildModule()
+# Module include folders
+include_directories(${AliRoot_SOURCE_DIR}/${MODULE})
+
+# Additional include directories in alphabetical order except ROOT
+include_directories(${ROOT_INCLUDE_DIRS}
+                    ${AliRoot_SOURCE_DIR}/STEER/STEERBase
+                   )
+# Sources in alphabetical order
+set(SRCS
+    AliTMinuitToolkit.cxx
+    TKDInterpolatorBase.cxx
+    TKDInterpolator.cxx
+    TKDNodeInfo.cxx
+    TKDPDF.cxx
+    TKDSpline.cxx
+    TStatToolkit.cxx
+  )
+
+# Headers from sources
+string(REPLACE ".cxx" ".h" HDRS "${SRCS}")
+
+# Generate the dictionary
+# It will create G_ARG1.cxx and G_ARG1.h / ARG1 = function first argument
+get_directory_property(incdirs INCLUDE_DIRECTORIES)
+generate_dictionary("${MODULE}" "${MODULE}LinkDef.h" "${HDRS}" "${incdirs}")
+
+# Generate the ROOT map
+# Dependecies
+set(LIBDEPS STEERBase Graf)
+generate_rootmap("${MODULE}" "${LIBDEPS}" "${CMAKE_CURRENT_SOURCE_DIR}/${MODULE}LinkDef.h")
+
+# Add a library to the project using the specified source files
+add_library(${MODULE} SHARED ${SRCS} G__${MODULE}.cxx)
+
+# Additional compilation flags
+set_target_properties(${MODULE} PROPERTIES COMPILE_FLAGS "")
+
+# Linking the library
+target_link_libraries(${MODULE} ${LIBDEPS})
+
+# System dependent: Modify the way the library is build
+if(${CMAKE_SYSTEM} MATCHES Darwin)
+    set_target_properties(${MODULE} PROPERTIES LINK_FLAGS "-undefined dynamic_lookup")
+endif(${CMAKE_SYSTEM} MATCHES Darwin)
+
+# Installation
+install(TARGETS ${MODULE}
+  ARCHIVE DESTINATION lib
+  LIBRARY DESTINATION lib)
+install(FILES ${HDRS} DESTINATION include)
+
+# Macros
+install(DIRECTORY Macros DESTINATION STAT)
+
+message(STATUS "${MODULE} enabled")
\ No newline at end of file