]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - THbtp/CMakeLists.txt
ATO-98 more verbose output for benchmark
[u/mrichter/AliRoot.git] / THbtp / CMakeLists.txt
index 8b593d955771b226fd1f9114bb3b1ac6400fd906..e5f8b84f72b7d20506ca9359a285986099b4a536 100644 (file)
@@ -1,25 +1,10 @@
-# -*- mode: cmake -*-
+# AliRoot Build System CMakeLists for THbtp
+#
+# Author: Johny Jose m(johny.jose@cern.ch)
+#         Port of previous Makefile build to cmake
 
-# Create a library called "lib<name>" which includes the source files given in
-# the array .
-# The extension is already found.  Any number of sources could be listed here.
+cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
 
-set(INCLUDE_DIRECTORIES
-${CMAKE_SOURCE_DIR}/THbtp
-${CMAKE_SOURCE_DIR}/STEER 
-${CMAKE_SOURCE_DIR}/EVGEN
-${ROOT_INCLUDE_DIR}
-)
-
-include_directories( ${INCLUDE_DIRECTORIES})
-
-set(LINK_DIRECTORIES
-${ROOT_LIBRARY_DIR}
-) 
-
-link_directories( ${LINK_DIRECTORIES})
-
-SetModule()
-
-include(CMake_libTHbtp.txt)
+file(GLOB PACKAGES CMake*.pkg)
 
+ALICE_BuildModule()