]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - TOF/CMakeLists.txt
Fixing small memory leaks (Hans)
[u/mrichter/AliRoot.git] / TOF / CMakeLists.txt
index 0601230de4b874b0284d37ea17fe79f42a185b6d..35421466f5160cf8b462e5c85b9e3c2455d508d9 100644 (file)
@@ -1,10 +1,28 @@
-# AliRoot Build System CMakeLists for TOF
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+add_subdirectory(TOFbase)
+add_subdirectory(TOFrec)
+add_subdirectory(TOFsim)
 
-file(GLOB PACKAGES CMake*.pkg)
+if(DA)
+    add_subdirectory(DA)
+endif(DA)
 
-ALICE_BuildModule()
+# Install the data folder
+install (DIRECTORY data DESTINATION TOF)
+
+
+message(STATUS "TOF enabled")