]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - TUHKMgen/CMakeLists.txt
Do not include from subdirectories
[u/mrichter/AliRoot.git] / TUHKMgen / CMakeLists.txt
index 4ad83f80470bb8747b6db6b3a911a022dc178187..995f326ce5f4fcc0de25a412dc0c8dd6f001c6bb 100644 (file)
@@ -1,26 +1,90 @@
-# -*- mode: cmake -*-
-
-# Create a library called "lib<name>" which includes the source files given in
-# the array .
-# The extension is already found.  Any number of sources could be listed here.
-
-set(INCLUDE_DIRECTORIES
-${CMAKE_SOURCE_DIR}/TUHKMgen
-${CMAKE_SOURCE_DIR}/TUHKMgen/UHKM
-${CMAKE_SOURCE_DIR}/STEER
-${CMAKE_SOURCE_DIR}/EVGEN
-${ROOT_INCLUDE_DIR}
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
+
+# Module
+set(MODULE TUHKMgen)
+
+# Module include folder
+include_directories(${AliRoot_SOURCE_DIR}/${MODULE}
+                    ${AliRoot_SOURCE_DIR}/${MODULE}/UHKM
+                   )
+
+# Additional include folders in alphabetical order except ROOT
+include_directories(${ROOT_INCLUDE_DIR}
+                    ${AliRoot_SOURCE_DIR}/EVGEN
+                    ${AliRoot_SOURCE_DIR}/STEER/STEER
+                    ${AliRoot_SOURCE_DIR}/STEER/STEERBase
+                   )
+
+# Sources
+set(SRCS
+    AliGenUHKM.cxx
+    TUHKMgen.cxx
+    UHKM/DatabasePDG.cxx
+    UHKM/DecayChannel.cxx
+    UHKM/EquationSolver.cxx
+    UHKM/GrandCanonical.cxx
+    UHKM/HadronDecayer.cxx
+    UHKM/HankelFunction.cxx
+    UHKM/InitialState.cxx
+    UHKM/InitialStateHydjet.cxx
+    UHKM/Particle.cxx
+    UHKM/ParticlePDG.cxx
+    UHKM/RandArrayFunction.cxx
+    UHKM/StrangeDensity.cxx
+    UHKM/StrangePotential.cxx
+    UHKM/UKUtility.cxx
 )
 
-include_directories( ${INCLUDE_DIRECTORIES})
+set(FSRCS
+    PYQUEN/progs_fortran.f
+    PYQUEN/pythia-6.4.11.f
+    PYQUEN/pyquen1_5.f
+   )
+
+# Headers from sources
+string(REPLACE ".cxx" ".h" HDRS "${SRCS}")
+
+# Generate the dictionary
+# It will create G_ARG1.cxx and G_ARG1.h / ARG1 = function first argument
+get_directory_property(incdirs INCLUDE_DIRECTORIES)
+generate_dictionary("${MODULE}" "${MODULE}LinkDef.h" "${HDRS}" "${incdirs}")
+
+# Generate the ROOT map
+# Dependecies
+set(LIBDEPS STEERBase STEER EVGEN)
+generate_rootmap("${MODULE}" "${LIBDEPS}" "${CMAKE_CURRENT_SOURCE_DIR}/${MODULE}LinkDef.h")
+
+# Add a library to the project using the specified source files
+add_library(${MODULE} SHARED ${SRCS} G__${MODULE}.cxx ${FSRCS})
 
-set(LINK_DIRECTORIES
-${ROOT_LIBRARY_DIR}
-) 
+# Additional compilation flags
+set_target_properties(${MODULE} PROPERTIES COMPILE_FLAGS "")
 
-link_directories( ${LINK_DIRECTORIES})
+# Linking the library
+target_link_libraries(${MODULE} ${LIBDEPS})
 
-SetModule()
+# System dependent: Modify the way the library is build
+if(${CMAKE_SYSTEM} MATCHES Darwin)
+    set_target_properties(${MODULE} PROPERTIES LINK_FLAGS "-undefined dynamic_lookup")
+endif(${CMAKE_SYSTEM} MATCHES Darwin)
 
-include(CMake_libTUHKMgen.txt)
+# Installation
+install(TARGETS ${MODULE}
+  ARCHIVE DESTINATION lib
+  LIBRARY DESTINATION lib)
+install(FILES ${HDRS} DESTINATION include)
 
+message(STATUS "${MODULE} enabled")