]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - ZDC/CMakeLists.txt
ALIROOT-5420 Changes for CDH v3
[u/mrichter/AliRoot.git] / ZDC / CMakeLists.txt
index 816eb0c625df7b7a6450669726a09a48745a4d8d..8fb14ed78f66d692153f63da7400b02aa60bad44 100644 (file)
@@ -1,29 +1,13 @@
-# -*- mode: cmake -*-
-# Create a library called "lib<name>" which includes the source files given in
-# the array .
-# The extension is already found.  Any number of sources could be listed here.
+# AliRoot Build System CMakeLists for ZDC
+#
+# Author: Johny Jose m(johny.jose@cern.ch)
+#         Port of previous Makefile build to cmake
 
-set(INCLUDE_DIRECTORIES
-${CMAKE_SOURCE_DIR}/ZDC
-${CMAKE_SOURCE_DIR}/STEER
-${CMAKE_SOURCE_DIR}/RAW
-${ROOT_INCLUDE_DIR}
-)
+cmake_minimum_required(VERSION 2.8.4 FATAL_ERROR)
 
-include_directories( ${INCLUDE_DIRECTORIES})
-
-set(LINK_DIRECTORIES
-${ROOT_LIBRARY_DIR}
-) 
-
-link_directories( ${LINK_DIRECTORIES})
-
-SetModule()
-
-include(CMake_libZDCsim.txt)
-
-include(CMake_libZDCrec.txt)
-
-include(CMake_libZDCbase.txt)
+file(GLOB PACKAGES CMake*.pkg)
 
+ALICE_BuildModule()
 
+install ( FILES "SpectatorSignal.root" "GlauberMCDist.root" 
+         DESTINATION ZDC )