Making the TPCLib compatible with the trunk of Jan 2009
authorrichterm <richterm@f7af4fe6-9843-0410-8265-dc069ae4e863>
Fri, 8 May 2009 14:30:11 +0000 (14:30 +0000)
committerrichterm <richterm@f7af4fe6-9843-0410-8265-dc069ae4e863>
Fri, 8 May 2009 14:30:11 +0000 (14:30 +0000)
commit53eb37862a18febe81f7bc9c3a4d14218ef6833b
tree95ebab3862fca1a75bbda0bbc164d7bbcf32e47d
parent678f8252198d50212d75fd16ef088f81c0d1ea52
Making the TPCLib compatible with the trunk of Jan 2009
- deleted deprecated include header from AliHLTTPCTransform
- using AliRunLoader::GetRunLoader instead of gAlice->GetRunLoader

Filter out more compiler defines when calling rootcint due to bug
https://savannah.cern.ch/bugs/?31089

Deactivate TRD module if dependency AliTRDclusterizer::GetAddedClusters not resolved

Adjust MUON module to compile with Jan 2009 trunk (before changes in r 31742 and 31769)
HLT/MUON/OnlineAnalysis/AliHLTMUONHitReconstructorComponent.cxx
HLT/MUON/OnlineAnalysis/AliHLTMUONTriggerReconstructorComponent.cxx
HLT/MUON/utils/AliHLTMUONDataCheckerComponent.cxx
HLT/SampleLib/Makefile.am
HLT/TPCLib/AliHLTTPCTransform.cxx
HLT/TPCLib/tracking-ca/AliTPCtrackerCA.cxx
HLT/configure.ac
HLT/make.dict