DARPM enables automatically DA
authoragrigora <alina.grigoras@cern.ch>
Wed, 17 Dec 2014 11:37:33 +0000 (12:37 +0100)
committeragrigora <alina.grigoras@cern.ch>
Wed, 17 Dec 2014 11:37:33 +0000 (12:37 +0100)
CMakeLists.txt
INSTALLDA.txt
cmake/FindFASTJET.cmake

index 720aa5e..1838b7b 100644 (file)
@@ -90,6 +90,13 @@ if(AMORE_CONFIG)
     endif()
 endif(AMORE_CONFIG)
 
+# id DARPM we enable DA if it is not set
+if(DARPM)
+    if(NOT DA)
+        set(DA ON)
+    endif(NOT DA)
+endif(DARPM)
+
 # DA is enabled
 if(DA)
     if(NOT DIMDIR AND NOT ODIR)
index fd5490d..8d19410 100644 (file)
@@ -109,6 +109,9 @@ DAs build and rpm creation are enabled through the cmake configuration parameter
     -DDA=ON
     -DARPM=ON
 
+DA set to ON will enable only the build of the DAs, but not the creation of the RPMs
+If DARPM is set to ON than DA is automatically enabled.
+
 The mandatory requirements have to be specified
     -DAMORE_CONFIG=PATH_TO_amore-config
     -DDATE_CONFIG=PATH_TO_date-config
index be99e1f..bd3c1ef 100644 (file)
@@ -56,7 +56,11 @@ if(FASTJET)
     string(REGEX REPLACE "^[0-9]+\\.[0-9]+\\.([0-9]+).*" "\\1" FASTJET_VERSION_PATCH "${FASTJET_VERSION}")
     
     if(FASTJET_VERSION_MAJOR LESS 3)
-        message(FATAL_ERROR "FastJet ${FASTJET_VERSION_MAJOR}.${FASTJET_VERSION_MINOR}.${FASTJET_VERSION_PATCH} version is not suported. Please install a version >= 3.*")
+        message(FATAL_ERROR "FastJet ${FASTJET_VERSION_MAJOR}.${FASTJET_VERSION_MINOR}.${FASTJET_VERSION_PATCH} version is not suported. Please install a version >= 3.0.*")
+    endif()
+    
+    if(FASTJET_VERSION_MINOR NOT EQUAL 0)
+        message(FATAL_ERROR "FastJet ${FASTJET_VERSION_MAJOR}.${FASTJET_VERSION_MINOR}.${FASTJET_VERSION_PATCH} version is not suported.  Please install a version >= 3.0.*")
     endif()
 
     # Extracting compilation flags