FastJet minimum version 3.*
authoragrigora <alina.grigoras@cern.ch>
Wed, 17 Dec 2014 09:39:49 +0000 (10:39 +0100)
committeragrigora <alina.grigoras@cern.ch>
Wed, 17 Dec 2014 09:42:13 +0000 (10:42 +0100)
cmake/FindFASTJET.cmake

index 3d1cb93..be99e1f 100644 (file)
@@ -54,6 +54,10 @@ if(FASTJET)
     string(REGEX REPLACE "^([0-9]+)\\.[0-9]+\\.[0-9]+.*" "\\1" FASTJET_VERSION_MAJOR "${FASTJET_VERSION}")
     string(REGEX REPLACE "^[0-9]+\\.([0-9])+\\.[0-9]+.*" "\\1" FASTJET_VERSION_MINOR "${FASTJET_VERSION}")
     string(REGEX REPLACE "^[0-9]+\\.[0-9]+\\.([0-9]+).*" "\\1" FASTJET_VERSION_PATCH "${FASTJET_VERSION}")
+    
+    if(FASTJET_VERSION_MAJOR LESS 3)
+        message(FATAL_ERROR "FastJet ${FASTJET_VERSION_MAJOR}.${FASTJET_VERSION_MINOR}.${FASTJET_VERSION_PATCH} version is not suported. Please install a version >= 3.*")
+    endif()
 
     # Extracting compilation flags
     execute_process(COMMAND ${FASTJET_CONFIG} --cxxflags OUTPUT_VARIABLE FASTJET_CXXFLAGS ERROR_VARIABLE error OUTPUT_STRIP_TRAILING_WHITESPACE )