we need -m64 when checking for libgfortran otherwise we get the 32bit version.

No match.