Added protections against using the wrong version of FRAME