corrected warnings with gcc 4.3