Changes needed to comply with the new version of AliGeomManager