Moving required CMake version from 2.8.4 to 2.8.8