Upgrade 4.0.17 clean.
[usit-rt.git] / etc / upgrade / 4.0.4 / content
1 @Initial = (
2     sub {
3         use strict;
4         my $templates = RT::Templates->new(RT->SystemUser);
5         $templates->Limit(
6             FIELD => 'Type',
7             OPERATOR => 'IS',
8             VALUE => 'NULL',
9         );
10         while (my $template = $templates->Next) {
11             my ($status, $msg) = $template->SetType('Perl');
12             $RT::Logger->warning( "Couldn't change Type of Template #" . $template->Id . ": $msg" ) unless $status;
13         }
14     },
15 );
16