Master to 4.2.8
[usit-rt.git] / etc / upgrade / 4.2.8 / content
1 use strict;
2 use warnings;
3
4 our @Initial = (
5     sub {
6         # This upgrade step is identical to the 4.2.7 upgrade, but only
7         # runs on Oracle because 4.2.7 was originally released with
8         # flawed SQL which did not run on Oracle.
9         return unless RT->Config->Get('DatabaseType') eq 'Oracle';
10         RT->DatabaseHandle->dbh->do(<<EOSQL);
11             DELETE FROM Attributes
12              WHERE (Name = 'LinkValueTo' OR Name = 'IncludeContentForValue')
13                AND (LENGTH(Content) = 0 OR Content IS NULL)
14 EOSQL
15     },
16 );