Putting 4.2.0 on top of 4.0.17
[usit-rt.git] / etc / upgrade / 4.0.4 / content
index fdfcb3e..4770289 100644 (file)
@@ -1,4 +1,7 @@
-@Initial = (
+use strict;
+use warnings;
+
+our @Initial = (
     sub {
         use strict;
         my $templates = RT::Templates->new(RT->SystemUser);
@@ -9,7 +12,7 @@
         );
         while (my $template = $templates->Next) {
             my ($status, $msg) = $template->SetType('Perl');
-            $RT::Logger->warning( "Couldn't change Type of Template #" . $template->Id . ": $msg" ) unless $status;
+            RT->Logger->warning( "Couldn't change Type of Template #" . $template->Id . ": $msg" ) unless $status;
         }
     },
 );