]> git.uio.no Git - check_openmanage.git/blob - nagios-plugins-check-openmanage.spec
bugfix
[check_openmanage.git] / nagios-plugins-check-openmanage.spec
1 # Definitions used throughout the spec file
2 %global plugin check_openmanage
3 %global nagiospluginsdir %{_libdir}/nagios/plugins
4
5 # No binaries here, do not build a debuginfo package
6 %global debug_package %{nil}
7
8 Name:          nagios-plugins-check-openmanage
9 Version:       3.7.0
10 Release:       1%{?dist}
11 Summary:       Nagios plugin to monitor hardware health on Dell servers
12
13 Group:         Applications/System
14 License:       GPLv3+
15 URL:           http://folk.uio.no/trondham/software/%{plugin}.html
16 Source0:       http://folk.uio.no/trondham/software/files/%{plugin}-%{version}.tar.gz
17
18 BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19
20 BuildRequires: perl
21
22 Obsoletes:     check_openmanage <= 3.6.3-1
23
24 %description
25 check_openmanage is a plugin for Nagios which checks the hardware
26 health of Dell servers running OpenManage Server Administrator
27 (OMSA). The plugin can be used remotely with SNMP or locally with
28 NRPE, check_by_ssh or similar, whichever suits your needs and
29 particular taste. The plugin checks the health of the storage
30 subsystem, power supplies, memory modules, temperature probes etc.,
31 and gives an alert if any of the components are faulty or operate
32 outside normal parameters.
33
34 %prep
35 %setup -q -n %{plugin}-%{version}
36
37 %build
38 pod2man -s 8 -r "%{plugin} %{version}" -c "Nagios plugin" %{plugin}.pod %{plugin}.8
39 pod2man -s 5 -r "%{plugin} %{version}" -c "Nagios plugin" %{plugin}.conf.pod %{plugin}.5
40
41 %install
42 %{__rm} -rf %{buildroot}
43 %{__install} -d -m 0755 %{buildroot}%{nagiospluginsdir}
44 %{__install} -d -m 0755 %{buildroot}%{_mandir}/man8
45 %{__install} -d -m 0755 %{buildroot}%{_mandir}/man5
46 %{__install} -pD -m 0755 %{plugin} %{buildroot}%{nagiospluginsdir}
47 %{__install} -pD -m 0644 %{plugin}.8 %{buildroot}%{_mandir}/man8
48 %{__install} -pD -m 0644 %{plugin}.conf.5 %{buildroot}%{_mandir}/man5
49
50 %clean
51 %{__rm} -rf %{buildroot}
52
53 %files
54 %defattr(-, root, root, -)
55 %doc README COPYING CHANGES
56 %{nagiospluginsdir}/*
57 %{_mandir}/man8/*.8*
58 %{_mandir}/man5/*.5*
59
60
61 %changelog
62 * Mon Aug 15 2011 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.7.0-1
63 - Version 3.7.0
64
65 * Tue Jun 06 2011 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.6.8-1
66 - Version 3.6.8
67
68 * Thu May 12 2011 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.6.7-1
69 - Version 3.6.7
70
71 * Thu Apr 28 2011 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.6.6-1
72 - Version 3.6.6
73
74 * Wed Feb  9 2011 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.6.5-1
75 - Version 3.6.5
76
77 * Tue Jan  4 2011 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.6.4-2
78 - Don't compress the man page, rpmbuild takes care of that. Thanks to
79   Jose Pedro Oliveira for a patch that fixes this.
80
81 * Tue Jan  4 2011 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.6.4-1
82 - Version 3.6.4
83 - Initial build with new spec file
84 - Spec file adapted to Fedora/EPEL standards
85
86 * Mon Dec 13 2010 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.6.3-1
87 - Version 3.6.3
88
89 * Thu Nov 25 2010 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.6.2-1
90 - Version 3.6.2
91
92 * Tue Nov  2 2010 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.6.1-1
93 - Version 3.6.1
94
95 * Mon Aug 30 2010 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.6.0-1
96 - Version 3.6.0
97
98 * Wed Jul 14 2010 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.5.10-1
99 - Version 3.5.10
100
101 * Tue Jun 29 2010 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.5.9-1
102 - Version 3.5.9
103
104 * Thu Jun 17 2010 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.5.8-1
105 - Version 3.5.8
106
107 * Wed Mar 19 2010 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.5.7-1
108 - Version 3.5.7
109
110 * Tue Feb 23 2010 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.5.6-1
111 - Version 3.5.6
112
113 * Fri Jan 22 2010 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.5.5-1
114 - Version 3.5.5
115
116 * Wed Jan 13 2010 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.5.4-1
117 - Version 3.5.4
118
119 * Thu Dec 17 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.5.3-1
120 - Version 3.5.3
121
122 * Tue Nov 17 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.5.2-1
123 - Version 3.5.2
124
125 * Thu Oct 22 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.5.1-1
126 - Version 3.5.1
127
128 * Tue Oct 13 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.5.0-1
129 - Version 3.5.0
130 - New location for the manual page (section 3 -> 8)
131
132 * Fri Aug  7 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.4.9-1
133 - Version 3.4.9
134
135 * Fri Jul 31 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.4.8-1
136 - Version 3.4.8
137
138 * Fri Jul 24 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.4.7-1
139 - Version 3.4.7
140
141 * Tue Jul  7 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.4.6-1
142 - Version 3.4.6
143
144 * Mon Jun 22 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.4.5-1
145 - Version 3.4.5
146
147 * Mon Jun 22 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.4.4-1
148 - Version 3.4.4
149
150 * Thu Jun 11 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.4.3-1
151 - Version 3.4.3
152
153 * Wed Jun  3 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.4.2-1
154 - Version 3.4.2
155
156 * Mon May 27 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.4.1-1
157 - Version 3.4.1
158
159 * Mon May 25 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.4.0-1
160 - Version 3.4.0
161
162 * Tue May  5 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.3.2-1
163 - Version 3.3.2
164
165 * Tue Apr 28 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.3.1-1
166 - Version 3.3.1
167
168 * Tue Apr  7 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.3.0-1
169 - Version 3.3.0
170
171 * Sun Mar 29 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.2.7-1
172 - Version 3.2.7
173
174 * Thu Mar  5 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.2.6-1
175 - Version 3.2.6
176
177 * Tue Feb 24 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.2.5-1
178 - Version 3.2.5
179 - take 64bit (other libdir) into consideration
180
181 * Tue Feb 17 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.2.4-1
182 - Version 3.2.4
183
184 * Mon Feb  9 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.2.3-1
185 - Version 3.2.3
186
187 * Tue Feb  3 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.2.2-1
188 - Version 3.2.2
189
190 * Tue Feb  3 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.2.1-1
191 - Version 3.2.1
192
193 * Tue Jan 27 2009 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.2.0-1
194 - Version 3.2.0
195
196 * Sat Dec 20 2008 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.0.2-1
197 - Version 3.0.2
198
199 * Thu Dec  4 2008 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 3.0.0-1
200 - Version 3.0.0
201
202 * Wed Nov 19 2008 Trond H. Amundsen <t.h.amundsen@usit.uio.no> - 2.1.0-0
203 - first RPM release