]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - ALIROOT/CMakeLists.txt
CMake: prepend_prefix() to every elm in a list
[u/mrichter/AliRoot.git] / ALIROOT / CMakeLists.txt
index f470f64ba244dcd5ea22a4bc0ac47c27ad3740f7..2dd24f2baec092ed16e20172fc5c4bc6dab09997 100644 (file)
@@ -1,10 +1,42 @@
-# AliRoot Build System CMakeLists for ALIROOT
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+# alieve executable
 
-file(GLOB PACKAGES CMake*.pkg)
+# Module include folder
+include_directories(${AliRoot_SOURCE_DIR}/ALIROOT)
 
-ALICE_BuildModule()
+# Additional include folders in alphabetical order
+include_directories(
+                    ${AliRoot_BINARY_DIR}/version
+                    ${AliRoot_SOURCE_DIR}/STEER/STEER
+                    ${AliRoot_SOURCE_DIR}/STEER/STEERBase
+                   )
+
+# aliroot executable
+# Sources in alphabetical order
+set(SRCS
+  aliroot.cxx
+)
+  
+set(CSRCS
+  fpu.c
+)
+
+add_executable(aliroot ${SRCS} ${CSRCS})
+target_link_libraries(aliroot MUONevaluation MUONmapping MUONshuttle MUONgraphics MUONsim MUONrec MUONgeometry MUONcalib MUONbase MUONraw MUONtrigger MUONcore TPCbase TPCsim TPCrec TPCutil  ITSbase ITSsim ITSrec PMDbase PMDsim PMDrec TRDbase TRDsim TRDrec FMDbase FMDsim FMDrec TOFbase TOFrec TOFsim PHOSUtils PHOSbase PHOSsim PHOSrec ADbase ADsim ADrec ACORDEbase ACORDEsim ACORDErec HMPIDbase HMPIDrec HMPIDsim ZDCbase ZDCsim ZDCrec VZERObase VZEROsim VZEROrec MFTbase MFTsim MFTrec EMCALUtils EMCALbase EMCALsim EMCALrec EMCALraw BCM STRUCT T0base T0sim T0rec FASTSIM microcern HLTbase HLTshuttle TRIGGERbase STEER STAT CDB AOD  STEERBase ESD ANALYSIS RAWDatasim RAWDatarec RAWDatabase Rint MLP)
+
+# Installation
+install(TARGETS aliroot RUNTIME DESTINATION bin)