]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - ANALYSIS/CMakeLists.txt
Split: removed CMake refs to OADB
[u/mrichter/AliRoot.git] / ANALYSIS / CMakeLists.txt
index 3b19633a7d2107a3e06a436e6641c8ec697f47a8..9e94b78dd24eaf28dd629247e02691fb86d030c1 100644 (file)
@@ -1,10 +1,24 @@
-# AliRoot Build System CMakeLists for ANALYSIS
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+add_subdirectory(ANALYSIS)
+add_subdirectory(ANALYSISalice)
+add_subdirectory(ANALYSIScalib)
+add_subdirectory(ESDfilter)
 
-file(GLOB PACKAGES CMake*.pkg)
+# Installing the macros
+install(DIRECTORY macros DESTINATION ANALYSIS)
 
-ALICE_BuildModule()
+message(STATUS "ANALYSIS enabled")