]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - HLT/Makefile.am
the final cut: PHOS compilation warnings (Oystein)
[u/mrichter/AliRoot.git] / HLT / Makefile.am
index da4c5af9427f280a87ca9ca2f385b645a320cbb4..870f4b5cda870d74f1856632ad5e61a0d0211777 100644 (file)
@@ -2,12 +2,23 @@
 # Makefile template for the Alice HLT framework and components
 
 
+if HAVE_ALIROOT
+ALIROOT_DEP=sim \
+           rec \
+           shuttle \
+           pendolino
+endif
+
 if EN_HLT_SAMPLE
 SAMPLE_DIR=SampleLib   
 endif
 
 if EN_HLT_TPC
-TPC_DIR=TPCLib 
+TPC_DIR=TPCLib
+endif
+
+if EN_HLT_RCU
+RCU_DIR=RCU
 endif
 
 if EN_HLT_PHOS
@@ -18,22 +29,68 @@ if EN_HLT_TRD
 TRD_DIR=TRD
 endif
 
+if EN_HLT_FMD
+FMD_DIR=FMD
+endif
+
+if EN_HLT_MUON
+MUON_DIR=MUON
+endif
+
+if EN_HLT_COMP
+COMP_DIR=comp
+endif
+
+if EN_HLT_TRIGGER
+TRIGGER_DIR=trigger
+endif
+
+if EN_HLT_ITS
+ITS_DIR=ITS
+endif
+
+if EN_HLT_EMCAL
+EMCAL_DIR=EMCAL
+endif
+
 SUBDIRS                = BASE \
+                         $(ALIROOT_DEP) \
+                         $(RCU_DIR) \
                          $(SAMPLE_DIR) \
                          $(TPC_DIR) \
                          $(PHOS_DIR) \
                          $(TRD_DIR) \
+                         $(FMD_DIR) \
+                         $(MUON_DIR) \
+                         $(COMP_DIR) \
+                          $(TRIGGER_DIR) \
+                          $(ITS_DIR) \
+                          $(EMCAL_DIR) \
                          doc
 
 EXTRA_DIST             = libHLTbase.pkg \
+                         libHLTinterface.pkg \
+                         libHLTsim.pkg \
+                         libHLTrec.pkg \
+                         libHLTshuttle.pkg \
+                         libHLTpendolino.pkg \
+                         libAliHLTHOMER.pkg \
                          libAliHLTUtil.pkg \
                          libAliHLTSample.pkg \
                          libAliHLTPHOS.pkg \
                          libAliHLTTPC.pkg \
                          libAliHLTTRD.pkg \
-                         src/AliHLTReconstructor.h \
-                         src/AliHLTReconstructor.cxx \
-                         hlt.conf
+                         libAliHLTFMD.pkg \
+                         libAliHLTMUON.pkg \
+                         libAliHLTComp.pkg \
+                         libAliHLTTrigger.pkg \
+                         libAliHLTRCU.pkg \
+                         libAliHLTITS.pkg \
+                         libAliHLTEMCAL.pkg \
+                         exa/sample-component1.C \
+                         exa/monitoring.C \
+                         hlt.conf \
+                         .revision
 
 DIST_SUBDIRS           = $(SUBDIRS)
 
@@ -58,6 +115,18 @@ SampleLibPkg: Makefile $(top_srcdir)/SampleLib/*
 clean-local: 
        (test ! -d SampleLibPkg || rm -rf SampleLibPkg)
 
+svn-update:
+       @cd $(top_srcdir) ;\
+       revision=`svn info 2> /dev/null | grep "Revision:" | cut -d ' ' -f 2 | tr -d '\n'` ;\
+       last=`svn info 2> /dev/null | grep "Last Changed Rev:" | cut -d ' ' -f 4 | cut -d '/' -f 4 | tr -d '\n'` ;\
+       if test "x$$revision" != "x" && test $$last -gt $$revision; then \
+               echo "The SVN copy is not up-to-date (revision $$revision - last update $$last), please 'svn update'"; \
+               exit -1; \
+       fi
+
+.revision: svn-update
+       @cd $(top_srcdir) ;\
+       svn info 2> /dev/null | grep "Revision:" | cut -d ' ' -f 2 | tr -d '\n' > $@
 #
 # EOF
 #