]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - HLT/configure.ac
Corrections for the TGeo interface. (A. Gheata)
[u/mrichter/AliRoot.git] / HLT / configure.ac
index 33ece15b410e9543f0de7ae1c153a23152416254..22ace9d92eb27400c1545de5e200db463529fbc2 100644 (file)
@@ -71,6 +71,10 @@ if test "x$have_root" = "x1"; then
   # has to derive from TBufferFile.h (needed for BASE/AliHLTMessage.h)
   AC_CHECK_HEADERS([TBufferFile.h])
 
+  # TView.h has been made pure virtual right after root v5-15-02 and one
+  # has to derive from TView3D.h (needed for TPCLib/OnlineDisplay/AliHLTTPCDisplay3D)
+  AC_CHECK_HEADERS([TView3D.h])
+
   CPPFLAGS=$save_CPPFLAGS
   LDFLAGS=$save_LDFLAGS
   LIBS=$save_LIBS
@@ -187,8 +191,19 @@ if test ! "x$have_aliroot" = "xno" ; then
                                       have_alirawdata=$CHECKLIB], 
                                      [have_alirawdata=no])
        ]) dnl AC_CHECK_LIB RAWDatabase
-  AC_MSG_CHECKING(for AliRawReader classes in RAWData libraries)
-  AC_MSG_RESULT($have_alirawdata)
+  AC_MSG_CHECKING([for AliRawReader classes in RAWData libraries])
+  AC_MSG_RESULT([$have_alirawdata])
+
+  dnl
+  dnl check whether AliLog supports notification callback
+  dnl
+  have_alilog_notification=no
+  AC_MSG_CHECKING([whether AliLog supports notification callback])
+  AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <AliLog.h>], 
+                                 [AliLog::AliLogNotification fct])],
+                                  [have_alilog_notification=yes], 
+                                 [AC_DEFINE(NO_ALILOG_NOTIFICATION)])
+  AC_MSG_RESULT([$have_alilog_notification])
 
   dnl
   dnl Check for the interface of AliExternalTrackParam which has been changed
@@ -298,6 +313,7 @@ if test ! "x$have_aliroot" = "xno" ; then
   LIBS=$save_LIBS
 fi
 AC_LANG_POP(C++)
+AC_SUBST([ALICE_ROOT])
 AC_SUBST([ALIROOT_CPPFLAGS])
 AC_SUBST([ALIROOT_LDFLAGS])
 AC_SUBST([ALIROOTBINDIR])
@@ -469,16 +485,17 @@ AM_CONDITIONAL(EN_HLT_TRD, test x$enable_trd = xyes)
 AC_MSG_RESULT([$enable_trd])
 
 dnl ------------------------------------------------------------------
-AC_MSG_CHECKING([whether to enable HLT logging])
-AH_TEMPLATE([NOLOGGING],[disable hlt logging])
-AC_ARG_ENABLE(logging,
-  [AC_HELP_STRING([--enable-logging],
-      [enable logging])],
-  [],[enable_logging=yes])
-if test "x$enable_logging" != "xyes" ; then 
-  AC_DEFINE(NOLOGGING)
+AC_MSG_CHECKING([whether to disable AliRoot logging])
+AH_TEMPLATE([NOALIROOT_LOGGING],[disable AliRoot logging])
+AC_ARG_ENABLE(aliroot-logging,
+  [AC_HELP_STRING([--disable-aliroot-logging],
+      [disable logging through AliRoot logging methods])],
+  [],[enable_aliroot_logging=no])
+if test "x$enable_aliroot_logging" != "xno" ; then 
+  AC_DEFINE(NOALIROOT_LOGGING)
 fi
-AC_MSG_RESULT([$enable_logging])
+AM_CONDITIONAL(NOALIROOT_LOGGING, test x$enable_aliroot_logging != no)
+AC_MSG_RESULT([$enable_aliroot_logging])
 
 dnl ------------------------------------------------------------------
 AC_MSG_CHECKING([whether to enable saving MC data through the chain])
@@ -547,6 +564,7 @@ AC_CONFIG_FILES([Makefile
                 BASE/Makefile
                 BASE/setenv.sh
                 BASE/setenv.csh
+                BASE/util/Makefile
                 SampleLib/Makefile
                 TPCLib/Makefile
                 TPCLib/mapping2array.cxx